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Workflow OP 1 - Linking Word Documents to 
MicroStation

This document guides you through the creation of CDOT Notes sheets. This includes general notes for each of 
the specialty groups, SWMP notes for Landscape and Environmental, as well as any other sheets with notes. 
The Design general notes will be illustrated in this workflow, but the process is the same for each type of notes 
sheet.

Workflow Outline

Updating Links to the Word Doc - The existing link in the notes file points to the seed Word document. 
This needs to be changed to point to the Word document in the project folder.

♦ Commands Used: Edit > Links > Change Source - Used to change the directory path to the linked 
Word document.

Editing the Notes - How the notes are edited will depend on the extent of the editing. If the edits do not 
change the line count of the document, the current link can be edited. If the edits will change the line count then 
the notes should be opened through Word and edited. After editing, the existing links in MicroStation must be 
deleted and re-created. 

♦ Commands Used: Double Click on Link - Used to open Word from MicroStation so that the existing 
link can be edited.

Setting Up a Word Document for Linking - If you are building a notes file from scratch, the page layout 
must be set up.

♦ Commands Used: Word > Page Layout - Used set up the page formatting.

○ Margins - Used to set the margins.

○ Size - Used to define the paper size.

○ Columns - Used to format to two columns.

○ Indents - Used to set the indents.

Creating a New Link - If a new notes file was created or if extensive edits were done on an existing file, a 
new link will need to be made.

○ Commands Used: MicroStation > Delete - Used to remove the old link.

○ Word > Copy - Used to identify the text to be linked.

○ MicroStation > Paste Special - Used to create the new link in MicroStation.

Updating Links to the Word Doc

The JPC#DES_GenlNote##.dgn is created in …\Design\Drawings project folder when the Create Project 
Utility is run. This file is linked to a Word document that contains generic notes. The links are pointing to the 
JPC#DES_GenNote.doc that resides in the Project Template and must be redirected to the file in the specific 
folder.

Note:

 A Word 2007 document has a maximum viewable width of 13” when linked to MicroStation.
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 A Word 2010 document has a maximum viewable width equal to the paper size when linked to 
MicroStation.

 When changing the source of a linked Word document in MicroStation, the viewable area of the document 
will match the version of Word installed on the computer.

♦ If a link containing a Word 2010 document has the source changed on a computer with Word 2007 
installed, the reduction of the viewable area will result in approximately 3” of data on the right side of 
the document being hidden. It may also affect fonts used in the Word document.

♦ If a link containing a Word 2007 document has the source changed on a computer with Word 2010 
installed, the image of the document is reduced in size to fit the entire paper area into the area of the 
existing link. It may also affect fonts used in the Word document.

1. Open the JPC#DES_GenlNote##.dgn located in ProjectWise or, for locally stored projects, C:\Proj-
ects\JPC#\Design\Drawings directory.

2. Select Edit > Links from the MicroStation Main Menu.
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3. In the Links dialog box, highlight one of the documents shown, then <D> Change Source.

4. In the Change Source dialog box, use the drop-down list next to the Look In field to select the desired 
directory.
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5. Highlight the JPC#DES_GenNote.doc file and <D> Open.

6. Repeat this process for the other link. 

7. <D> Cancel to dismiss the Change Source dialog box.

Note: both links use the same JPC#DES_GenNote.doc.

Editing the Notes

1. The General Note text document is located in the project directory under: 

C:\Projects\JPC#\Design\Drawings\Tabs\JPC#DES_GenNote.doc

2. This file is then linked twice to the JPC#DES_GenlNote##.dgn sheet files, once for each sheet border in 
the file. These links act independently of each other, however. Adding or deleting text from one link will 
not scroll text to the other link. 

3. Editing that will not change the number of lines in the Word document can be done through the existing 
link in the JPC#DES_GenlNote##.dgn file. For editing that will change the line count, open the 
JPC#DES_GenNote.doc and make the desired changes. After changes are made, delete the existing links 
in the JPC#DES_GenlNote##.dgn file and create new ones from the edited Word document.

Editing an Existing Link

1. Select the Element Selector tool from the MicroStation Main toolbar.
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2. Move the cursor on to the edge of the linked text (the edge will highlight) and double click (<D> <D>). 
This will open the JPC#DES_GenNote.doc file in a session of Word.

3. Make the desired changes in the text, Save, and Close the Word document. The changes will be 
automatically displayed in the JPC#DES_GenlNote##.dgn file.

4. Select Edit > Update Links so that the change will show in document.

Setting Up a Word Document for Linking

The following section contains guidelines for setting up a Word document for linking to MicroStation. Please 
be aware that MicroStation interprets Word 2007 documents and Word 2010 documents differently. Because of 
this, the setting for both Word 2007 and Word 2010 are given below. Other information, detailed below the 
page set-up section, pertains equally to both versions of Word.

Page Set-up for Word Documents

 Settings for Word 2007

The following settings are used when creating a new Word 2007 document for General Notes or SWMP Plans.

Page Size 11x17 (11” x 17”)

Orientation Landscape

Top Margin 1.00”

Bottom Margin 1.40”

Left Margin 1.00”

Right Margin 3.00”

Columns Two

Column 1 Width 6.25”

Column 2 Width 8.85”

Column Spacing 0.00”

Column 1 Left Indent 0.13”

Column 1 Right Indent 0.15”

Column 2 Left Indent 0.50” for General Notes 0.13” for SWMP Plans

Column 2 Right Indent 2.35” for General Notes 2.22” for SWMP Plans

Font Arial Monospaced for SAP

Font Size 10

Note: Due to the column with limitations with Word 2007, use an 8 point font size for Word 2007 General 
Notes and SWMP sheets. 

Note: The Arial font should be used in documents where items are not put into columns. The Arial 
Monospaced for SAP font is required for columns of data to line up correctly
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Settings for Word 2010

The following settings are used when creating a new Word 2010 document for General Notes or SWMP Plans.

Page Size 11x17 (11” x 17”)

Orientation Landscape

Top Margin 0.50”

Bottom Margin 0.50”

Left Margin 0.25”

Right Margin 0.25”

Columns Two

Column 1 Width 8.00”

Column 2 Width 8.00”

Column Spacing 0.50”

Column 1 Left Indent 0.00”

Column 1 Right Indent 0.00”

Column 2 Left Indent 0.00”

Column 2 Right Indent 0.00”

Font Arial Monospaced for SAP

Font Size 10

Note: The Arial font should be used in documents where items are not put into columns. The Arial 
Monospaced for SAP font is required for columns of data to line up correctly.

General Information for Creating Word Documents

 The Auto-numbering function in Word will not function properly. Once the copied text is pasted into 
MicroStation, the first item of the copied text is renumbered starting at 1. This occurs even if the auto-
numbering is set to start with a number other than 1.
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 If you wish to number the items, set the Indentation Special to Hanging with a By value of 0.25”, then 
physically type in the numbers. Also, clear any tabs set, as these may cause problems with the formatting.

Note: The image above shows the indents for a 2007 Word document. The Left and Right Indentation 
settings are 0.00 for a 2010 Word document.

 Use a “hard” return (by pressing the Enter key) at the end of each page. This will ensure that there is no 
text wrapping between pages.

 A Word 2007 document has a maximum viewable width of 13” when linked to MicroStation.

 A Word 2010 document has a maximum viewable width equal to the paper size when linked to 
MicroStation.

 When changing the source of a a linked Word document in MicroStation, the viewable area of the 
document will match the version of Word installed on the computer.

♦ If a link containing a Word 2010 document has the source changed on a computer with Word 2007 
installed, the reduction of the viewable area will result in approximately 3” of data on the right side of 
the document being hidden. It may also affect fonts used in the Word document.

♦ If a link containing a Word 2007 document has the source changed on a computer with Word 2010 
installed, the image of the document is reduced in size to fit the entire paper area into the area of the 
existing link. It may also affect fonts used in the Word document.

Preparing Word Documents that Contain a Table

Some Word documents, like the SWMP plan sheets contain tables. If the table does not fit into a single column 
it may not display correctly when pasted into MicroStation. One method of correcting this problem is 
explained below.
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The illustration below shows a table running on to two pages.

1. <R> in the first cell of the first row of the table that is on the second page.

2. From the right click menu, select Insert > Insert Rows Above. This adds a blank row of cells at the top of 
the second sheet.

3. Next, highlight the heading row of the table.
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4. <R> in any cell in the heading row and select Copy from the right click menu.

5. <R> in the first cell of the blank row added above and select Paste from the right click menu.
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Now both pages of the table will have the proper header and can be linked to MicroStation.

Note: On tables such as the one shown above, if the table is divided at a location where a cell contains two 
lines of text, make sure that both lines of text are visible in the row at the end of the first page and the 
beginning of the second page. If a line of text is “lost” between the pages, the table will not copy 
properly. Adding a blank row above the row with the missing line will correct this problem.

Preparing the Documents in ProjectWise

Linking a ProjectWise document to a MicroStation drawing allows you to change the document and have those 
changes automatically reflected in the MicroStation drawing. This is a two stage process. The first step is to 
create a logical set of documents called a Document Set. The second step is to use the set to link the documents 
with the MicroStation drawing.

Creating a Document Set

1. In the ProjectWise Explorer select the folder where the parent drawing is located. This will usually be the 
\Drawings folder of the specialty group.

2. Right-click on the parent drawing file and select Set > New from the right click menu. This will display 
the Create Document Set dialog box.
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3. Enter a Name: and Description: for the new document set. Consider using the name of the MicroStation 
file as the Name: of the new document set. This will help with knowing which document set is associated 
with a drawing. Click OK.

The Document Set window will appear with the parent drawing listed in the window.

4. Next, Drag and drop any Excel or Word documents that will be referenced to the parent drawing into 
the document set window.

Note: Although documents can be added to the Document Set from any folder within the active 
ProjectWise datasource, ideally they would be added from folders within the same project.
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5. Once all of the desired documents are added to the document set, close the document set window. The 
Document Set will appear in the ProjectWise Explorer window as indicated by the  icon. Notice how 
the document set has a Name but no FileName as shown below.

Note: A document set is not a file and therefore cannot exist outside of ProjectWise.

Using the document set, all files associated with the drawing file can be checked in/out together. It ensures 
that the correct files are being used in the linked document and are available to other team members when 
changes are made to the base files.

Creating a New Link

Use the following procedure when changes to the JPC#DES_GenNote.doc will increase or decrease the 
original number of lines in the document.

1. Select Delete from the MicroStation Main toolbar.

2. <D> on the linked text. <D> again to accept the command and delete the link.
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3. Open the edited JPC#DES_GenNote.doc and highlight the entire page of text that is to be linked.

4. Select Edit > Copy from the menu (or press CTRL + C) to copy the text to the clipboard.

5. Go to the MicroStation session with the JPC#DES_GenlNote##.dgn file open and select Edit > Paste 
Special.



LWDM- 14 Colorado Department of Transportation

 Linking Word Documents to MicroStation CDOT  Workflows

6. From the Paste Special window, select Linked Microsoft Office Word Document, then <D> Paste.

7. In the Paste OLE tool dialog box, set the Method to By Corners.

8. <T> to the left end of the guide line and <D>.

9. <T> to the right end of the guide line and <D> to complete the link.

An alternative method when attaching the linked document is to use the size option in the Paste OLE dialog 
box. 

1. Follow steps 1 through 6 described above.

2. In the Paste OLE tool dialog box, set the Method to By Size.
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3. Expand the dialog box and set the Scale to 13.00.

Note: Using the 13 scale factor will produce a text height of approximately.07”, which is the CDOT standard 
for a 1”=1’ annotation scale. This number can be adjusted if larger text is required.

4. Center the outline of the link in the sheet border and <D> to place it.

Once the linked document has been placed, it can be repositioned using the MicroStation Move command.
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Notes Placed From a PDF
A PDF file of the notes can be displayed within the MicroStation file to create General Notes and SWMP plan 
sheets. As with the other options, using a PDF file has advantages and disadvantages. Some of the advantages 
to using a PDF file are:

♦ The Word 2010 formatting can be used even on computers with Word 2007

♦ The autonumbering functions in Word can be used

♦ If the PDF is recreated, the new PDF in MicroStation is updated as well

Some of the disadvantages to using a PDF are:

♦ The Word file can be different from the PDF file. You will need to create a new PDF each time the 
document is edited

♦ A separate PDF is required for each page in the document

♦ A PDF that is attached in MicroStation cannot be overwritten while the DGN file is open. 

○ Close MicroStation.

○ Create a new pdf. Give it the same name to overwrite the existing one.

○ Open up MicroStation and PDF will be updated

To link a PDF to MicroStation, follow the steps below:

1. Open the Word document (the JPC#DES_GenNote_2010.doc is used in this example) and create a separate 
PDF print of each sheet to be linked.

Note: Be sure to name the PDF something meaningful for the print (in this example the PDF was named 
JPC#DES_GenNote_2010-pg1.pdf ).

2. ).Open MicroStation using the drawing that will contain the PDF (in this example 
JPC#DES_GenNote_2010.dgn is used). 
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3. Open the MicroStation Raster Manager.

4. In the Raster Manager dialog box, select File > Attach > Raster. This displays the Attach Raster 
Reference dialog box.

5. In the Attach Raster Reference dialog box, navigate to the desired location, highlight the desired file, and 
toggle on Place Interactively.

6. <D> the Open button.
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7. <T> to the left end of the bottom snap line within the sheet border then <D>.

8. <T> to the right end of the bottom snap line within the sheet border then <D>.
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This completes the attachment of the PDF file. Below is an example of a completed sheet.
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Notes Placed as MicroStation Elements

Included in the workspace are files called JPC#DES_GenlNoteMsta##.dgn and JPC#DES_SWMP‐Msta.dgn. 
These are MicroStation files that have the respective notes placed as MicroStation text elements instead of 
using links to Word. These files do not have an external data source and all editing occurs solely within the 
MicroStation environment using the Edit Text command.
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If used, these files should replace those containing the linked Word documents and should not be used in 
addition to them.
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